GUI Reference Overview

GUI Overview

T-Plan Robot Enterprise Graphical User Interface (GUI) is based on Java Swing and is platform independent. It consists of the main application window and a set of child windows (dialogs).

  1. Menu and Tool Bar provide structured access to most of the application functionality.
    Help Topic: Menu And Tool Bar Reference
  2. Tool Panel is a tabbed pane allowing quick access to often used minor features working with functionality of the script editor, desktop viewer and/or the underlying desktop client.
    Help Topic: Tool Panel
  3. Script Editor is designed to enable easy script editing and execution. It provides a wide range of features, from scripting language syntax highlighting and GUI assisted composure of automation code to abilities to execute just the selected piece of code and to set up execution break points.
    Help Topic: Script Editor
  4. Desktop Viewer displays desktop of the system. When the tool is not connected or it works with the local desktop, the viewer displays an HTML document with links to documentation and other web resources.
    Help Topic: Desktop Viewer
    Scheduler uses the viewer area when it gets opened.  It creates and maintains suites (called "schedules") which define sequences of one or more scripts to be executed within a single Robot process.
    Help Topic: Schedules
  5. Status Bar is used by all components to display status messages, desktop update rectangle and mouse coordinates.
    Help Topic: Status Bar


A catalog of child windows ordered by their appearance in the menu/tool bar follows:

The New Project and Project Properties create and/or edit a project. The window can be opened through the File->New Project menu item or through the New Project or Project Properties menu items of the Project View root node right click context menu. 

Help Topic: Projects

The New Script window creates a new script and populates it with the basic settings of output and template paths and the result file (report). It is available through the File->New Script menu item or through the New Script menu item of the Project View script node right click context menu.

The Conversion To Java wizard exports TPR script(s) (.tpr) to Java source code (.java). It is available through the File->Export To Java menu item or from the TPR editor context menu.

Help Topic: Conversion To Java

The Find/Replace is a very simple window allowing to search and eventually replace strings in the active script editor. It may be opened through the Edit->Find/Replace menu item or the corresponding tool bar button.

The Go To Line allows to jump to a particular line number in the active script editor. It is available through the Edit->Go To Line menu item.

The Code Templates window allows to create and maintain script code templates. It is available through the Edit->Code Templates menu item.

Help Topic: Code Templates

The Preferences Window enables to edit application wide configuration parameters and customise T-Plan Robot Enterprise behaviour. It has a form of a tree where each tree node represents a topic and/or a particular component. A panel with available configuration parameters is displayed on the right when the tree node gets selected. The window may be started through the Edit->Preferences menu item or the corresponding tool bar button. Many components also provide quick links to their configuration tree node through a context (pop up) menu.

Help Topic: Preferences Window

The Screeenshot Command window provides a comfortable way of creating an instance of the Screenshot command in the active editor. It may be started through the Script->Screenshot Command menu item or the corresponding tool bar button. It is also possible to open the window through the context menu (right mouse click) of an already existing Screenshot command in the active editor.

Help Topic: Screenshot Command Window

The CompareTo Command window provides a comfortable way of creating an instance of the CompareTo command in the active editor. It may be started through the Script->CompareTo Command menu item or the corresponding tool bar button. It is also possible to open the window through the context menu (right mouse click) of an already existing CompareTo command in the active editor.

Help Topic: CompareTo Command Window

The WaitFor Command window provides a comfortable way of creating an instance of the WaitFor match and mismatch commands in the active editor. It may be started through the Script->WaitFor Command menu item or the corresponding tool bar button. It is also possible to open the window through the context menu (right mouse click) of an already existing WaitFor command in the active editor.

Help Topic: WaitFor Command Window

The Image Doctor Records window keeps track of failed image comparisons collected by the Image Doctor. It may be opened through the Script->Image Doctor Records menu item.

Help Topic: Image Doctor

The Image Doctor Warning window gets displayed when an image comparison fails while a script is being executed and the Image Doctorimgdoctorwizard is on.

Help Topic: Image Doctor

The Login Window allows to connect to a desktop. It displays as the very first window when the application gets started without any connection options. The window is also reachable through the Desktop->Connect Desktop and under certain conditions also Desktop->Reconnect Desktop menu items.

Help Topic: Login Window

The Keyboard Tool allows to construct a keyboard key and press it on the remote desktop and/or insert the corresponding command or Java method call into the active script editor. The tool may be started through the Tools->Keyboard Tool menu item.

Help Topic: Keyboard Tool

The Take A Screenshot window allows to save image of the current desktop or its rectangular part to a file. It is accessible through the Tools->Take A Screenshot menu item.

Help Topic: Take A Screenshot

The Plugin Manager allows to install, enable, disable and uninstall plugins. To open it select the Tools->Plugins menu item.

Help Topic: Plugin Manager Window

The Component Capture component offers a comfortable way of creating a template image directly from the desktop viewer and generating of a predefined action into the active script editor.

Help Topic: Component Capture

The Import T-Plan Script creates an automated script template based on a script entity in the T-Plan database. The window is part of integration with T-Plan Professional 7.0. To open it select the Tools->Import T-Plan Script menu item.

Help Topic: Integration Reference

The Export Results To T-Plan exports results to the T-Plan database. The window is part of integration with T-Plan Professional 7.0. To open it select the Tools->Export Results To T-Plan menu item.

Help Topic: Integration Reference

The License Key Manager is a simple window allowing to add or remove license keys. It displays automatically on startup when no valid license is installed. It is also available through the Tools->License Key Manager menu item. Role of license keys is described in the Release Notes

The Update & Upgrade window exposes T-Plan Robot Enterprise releases from the T-Plan release server and allows to download new software versions and/or upgrade the current installation. To open it select the Tools->Update & Upgrade menu item.

Help Topic: Update & Upgrade

The Result Manager keeps track of results produced by scripts since the application start and allows their viewing, editing and saving. It displays automatically when a manually executed script in GUI mode finishes and produces a set of results. It is also available through the Tools->Result Manager. The window may be also displayed in CLI mode when the m/-resultmanager CLI option is specified.

Help Topic: Result Manager

The Export Script Comments window allows to process comments present in the main script body and export them to a file. It is available through the Tools->Export Script Comments menu item.

Help Topic: Comment Exporter

The Character Image Capture wizard creates and maintains character image collections used by the Image Based Text Recognition algorithm . It is available through the Tools->Character Capture menu item.

Help Topic: Image Based Text Recognition

The About Window is available through Help->About and displays the copyright and license text as well as system properties (configuration) of the Java Runtime Environment (JRE).

The Log Viewer displays the available T-Plan Robot Enterprise application logs capturing the messages printed into the standard and error output streams (typically the console/terminal or command prompt). It is available through the Help->Log Viewer menu item.

Help Topic: Log Viewer

The Help Window displays content of the help topics bundled inside the T-Plan Robot Enterprise binaries. User can also select to open the help document in a web browser instead. The help content is available either through the Help->Help Topics menu item or the "Open Help" and "Contextual Help" tool bar buttons. Many components also provide quick links to their help topics.

The Template Image Editor allows to edit template images employed for image comparison. The window is available from any GUI component involved in image comparison, such as the CompareTo, Screenshot and Waitfor match/mismatch windows.

Help Topic: Template Image Editor

The Scheduler creates and maintains suites (called "schedules") which define sequences of one or more scripts to be executed within a single Robot process.

Help Topic: Schedules